首頁 股票學校 股票入門 選股 買入 看盤 跟莊 短線 炒股技巧 技術指標 k線圖 MACD 均線 成交量 股票書籍 股票視頻 網站導航

767股票學習網 > 股票學校 > 通達信公式 > 正文

通達信指標:空中加油主副圖

空中加油主圖

MA5:MA(CLOSE,5),linethick1;
MA10:MA(CLOSE,10),linethick1;
MA20:MA(CLOSE,20),linethick2;
MA30:MA(CLOSE,30),linethick1;
MA250:MA(CLOSE,250),COLORff3399,linethick3;
N1:=BARSLAST(CROSS(MA5,MA10));
N2:=BARSLAST(CROSS(MA10,MA5));
多:=IF(N1<N2,N1+1,0);
空:=IF(N2<N1,N2+1,0);
QSXS:=MA5>MA20 AND MA10>MA20 AND MA20>REF(MA20,1) 
AND MA30>REF(MA30,1);
啟動:=多*QSXS,COLORRED,LINETHICK0;
跑道:=空*QSXS,COLORFFFF00,LINETHICK0;
HKFJ:=HHV(多,5)>=2 AND QSXS AND MA5>REF(MA5,1) AND MA5>MA10;
航空飛機:=HKFJ*多,COLORFF00FF,LINETHICK2;
HKSJ:=BARSLAST(航空飛機>0 AND NOT(REF(航空飛機,1)))+1;
高度:=(C/REF(C,HKSJ)-1)*100,COLOR00FFFF;
空中加油:啟動>0 AND 航空飛機=0,COLOR00FF00,POINTDOT,LINETHICK0;
N3:=BARSLAST(空中加油)+1;
K5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.14159;
JXGD1:=K5>REF(K5,1) AND REF(K5,1)<REF(K5,2);
JXGD2:=MA5>REF(MA5,1) AND REF(MA5,1)<REF(MA5,2);
加速遠航:FILTER((JXGD1 OR JXGD2) 
AND C>MA5 AND HKFJ,3),COLOR00FFFF,POINTDOT,LINETHICK0;
N4:=BARSLAST(加速遠航);
{以下設置主圖顯示方式}
STICKLINE(空中加油,(O+C)/2-0.01,(O+C)/2+0.01,4,0),COLOR00FF00;
STICKLINE(空中加油,L,H,1,1),COLOR00FF00;
STICKLINE(加速遠航,(O+C)/2-0.01,(O+C)/2+0.01,4,0),COLOR00FFFF;
STICKLINE(加速遠航,L,H,1,1),COLOR00FFFF;
STICKLINE(N4>0 AND N4<=5,REF(O,N4+1),REF(O,N4+1),4,1),COLORFFFFFF;
DRAWTEXT(加速遠航,L,'加▲速'),COLOR00FFFF;
DRAWTEXT(航空飛機,MA30,'○'),COLORFFFFFF;
DRAWTEXT(空中加油,MA30,'□'),COLOR00FF00;



{空中加油副圖}
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
MA30:=MA(CLOSE,30);
MA250:=MA(CLOSE,250),COLORRED;
N1:=BARSLAST(CROSS(MA5,MA10));
N2:=BARSLAST(CROSS(MA10,MA5));
多:=IF(N1<N2,N1+1,0);
空:=IF(N2<N1,N2+1,0);
QSXS:=MA5>MA20 AND MA10>MA20 AND MA20>REF(MA20,1) 
AND MA30>REF(MA30,1);
啟動:多*QSXS,COLORRED,LINETHICK0;
跑道:空*QSXS,COLORFFFF00,LINETHICK0;
HKFJ:=HHV(多,5)>=2 AND QSXS AND MA5>REF(MA5,1) AND MA5>MA10;
航空飛機:HKFJ*多,COLORFF00FF,LINETHICK2;
HKSJ:=BARSLAST(航空飛機>0 AND NOT(REF(航空飛機,1)))+1;
高度:(C/REF(C,HKSJ)-1)*100,COLOR00FFFF;
空中加油:啟動>0 AND 航空飛機=0,COLOR00FF00,POINTDOT,LINETHICK0;
N3:=BARSLAST(空中加油)+1;
K5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.14159;
JXGD1:=K5>REF(K5,1) AND REF(K5,1)<REF(K5,2);
JXGD2:=MA5>REF(MA5,1) AND REF(MA5,1)<REF(MA5,2);
加速遠航:FILTER((JXGD1 OR JXGD2)
AND C>MA5 AND HKFJ,3),COLOR00FFFF,POINTDOT,LINETHICK0;
N4:=BARSLAST(加速遠航);
{以下設置副圖顯示方式}
STICKLINE(空中加油,0,啟動/10+1,4,1),COLOR00FF00;
STICKLINE(N4>0 AND N4<=5,REF(啟動,N4+1),REF(啟動,N4+1),4,0),COLORFFFFFF;
DRAWTEXT(加速遠航,啟動,'▲'),COLOR00FFFF;
{指標使用方法:
1、啟動跑道可關注,航空飛機安全行;空中加油等買票,加速遠航好收益!
2、啟動時間長又長,航天飛機要遠航!
3、啟動時間長,均線越順暢;航天飛機快,登上要坐好!}  

上一篇文章:

下一篇文章:

 




767股票學習網 | 手機版 | 微信 | 微博 | 聯系站長





腾讯麻将怎么玩
北京时时官网 竞彩2串1稳单大神 新疆时时三星基本走势图 北京pk赛车彩票平台 北京时时仪骗局 排列三杀一码推荐 推牌9的十赌九赢秘诀 极速赛车手机计划平台 北京pk赛车人工1期计划 重庆时时彩内部公式