首頁 股票學校 股票入門 選股 買入 看盤 跟莊 短線 炒股技巧 技術指標 k線圖 MACD 均線 成交量 股票書籍 股票視頻 網站導航

767股票學習網 > 股票學校 > 通達信公式 > 正文

通達信指標:七劍下天山

七劍下天山


E1:=BARSCOUNT(C);
AH:=HHV(H,200);
AL:=LLV(L,200);
B0:=(AH-AL)/40;
KB1:=H+B0;
KB2:=L-B0;
STICKLINE((E1+0)/34=FLOOR((E1+0)/34),KB2,KB2-3*B0,1,0),COLORYELLOW,LINETHICK3;
DRAWTEXT((E1+0)/34=FLOOR((E1+0)/34),KB2-2*B0,'時間窗'),COLORWHITE;
{STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,5,0),COLORFF6C00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,4,0),COLORFF7B00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,3,0),COLORFF9C00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,2,0),COLORFFBE00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,2.5,0),COLORFFCC00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,1.5,0),COLORFFFF00;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,6,0),COLOR070084;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,5,0),COLOR0000A3;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,4,0),COLOR0000B7;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,3,0),COLOR0000CD;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,2,0),COLOR0000E9;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,2,0),COLOR0754E9;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1.5,0),COLOR076EF3;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1,0),COLOR077BF3;
STICKLINE((CLOSE > OPEN),OPEN,LOW,1,0),COLOR0726CA;
STICKLINE((CLOSE > OPEN),CLOSE,HIGH,1,0),COLOR0726CA;
STICKLINE((OPEN > CLOSE),CLOSE,LOW,1,0),COLORDE9100;
STICKLINE((OPEN > CLOSE),OPEN,HIGH,1,0),COLORDE9100;}
賣出線:=98;
階段賣:=96;
趨勢4:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA
(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
底部:=10;
買入信號RAWICON(CROSS(趨勢4,底部),LOW,1);
賣出RAWICON(CROSS(賣出線,趨勢4),HIGH,2);
頂壓:HHV(MA(H,11),50),COLORFF9900,LINETHICK3;
短壓:HHV(MA(H,11),15),COLOR0066FF,LINETHICK3;
XL1:=LLV(MA(H,11),1);
趨勢3:IF(XL1>=短壓,短壓,XL1),COLORRED,LINETHICK2;
K1:=BACKSET(趨勢3<REF(趨勢3,1),2);
IF(K1,趨勢3,DRAWNULL),COLOR00CC33,LINETHICK2;

RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
KK1:=REF(RSV,1);KK2:=REF(RSV,2);KA:=RSV;KK3:=REF(RSV,3);KK4:=REF(RSV,4);KK5:=REF(RSV,5);
KK80:=3*80-(POW(2/3,1)*KK1+POW(2/3,2)*KK2+POW(2/3,3)*KK3+POW(2/3,4)*KK4+3*POW(2/3,5)*KK5);
KKK80:=SMA((KK80*(HHV(H,9)-LLV(L,9))/100)+LLV(L,9),3,1);
交叉:=3*SMA(SMA(KA,3,1),3,1)-(POW(2/3,1)*KK1+POW(2/3,2)*KK2+POW(2/3,3)*KK3+POW(2/3,4)*KK4+3*POW(2/3,5)*KK5);
K轉折:=3*SMA(KA,3,1)-(POW(2/3,1)*KK1+POW(2/3,2)*KK2+POW(2/3,3)*KK3+POW(2/3,4)*KK4+3*POW(2/3,5)*KK5);
K轉折價0:=SMA((K轉折*(HHV(H,9)-LLV(L,9))/100)+LLV(L,9),3,1);
日交叉0:=SMA((交叉*(HHV(H,9)-LLV(L,9))/100)+LLV(L,9),3,1);
DRAWTEXT(K轉折價0>=KKK80 AND K轉折價0>=日交叉0,日交叉0,'◆'),COLORFF00FF;
趨勢:= 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1) 
-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),
COLORYELLOW,LINETHICK2; 
警戒:=趨勢<=5 ; 
D1:=C/L>1.05 AND COUNT(警戒,3)>=1 AND C/REF(C,1)>1.01; 
DRAWTEXT(D1>0,L,'★長生劍'),COLOR00FF00;
趨勢1:= MA(3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),5); 
買入1:= C/O>1.04 AND COUNT(趨勢1<10,3)>=1; 
D2:=(買入1); 
DRAWTEXT(D2>0,L,'☆孔雀翎'),COLORFF00FF;
M1:=(CLOSE-MA(CLOSE,30))/STD(CLOSE,15)*100; 
K:=SMA(M1,3,1); 
D:=SMA(K,3,1); 
J:=3*K-2*D; 
DD:=M1<-300; 
DA:=C/O>1.04 AND COUNT(M1<-300,3)>=1;
D3:=DA; 
DRAWTEXT(D3>0,L,'★碧玉刀'),COLOR006EFF;
個股:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100; 
D4:=COUNT(個股<-8,3)>=1 AND ( C/L>1.05 ) ; 
DRAWTEXT(D4>0,L,'◎多情環'),COLORRED;
LCA:=REF(CLOSE,1); 
E:=-100*(HHV(HIGH,84)-CLOSE)/(HHV(HIGH,84)-LLV(LOW,84)); 
底:=(( E<-98)*2000); 
D5:=( C/L>1.04 AND C>REF(C,1)) AND COUNT(底,2)>=1;
DRAWTEXT(D5>0,L,'Ψ離別鉤'),COLOR0090E0;
DIFFA:=(EMA(CLOSE,12) - EMA(CLOSE,26))*100+50;
DC:=C/L>1.05 AND DIFFA<40;
D6 :=FILTER(DC,5);
DRAWTEXT(D6>0,L,'↑霸王槍'),COLOR00FF00;
BB1:=LLV(LOW,5)=LLV(LOW,45) AND CLOSE>=OPEN*1.035 ; 
BB2:=CLOSE>(REF(HIGH,1)+REF(LOW,1))/2; 
BB3:=(CLOSE-OPEN)/OPEN*100; 
BB4:=REF(CLOSE,1); 
BB5:=SMA(MAX(CLOSE-BB4,0),6,1)/SMA(ABS(CLOSE-BB4),6,1)*100; 
BB6:=COUNT(BB5<20,20)>=1; 
BB108:=BB3>9 AND BB6; 
BB7:=(CLOSE-OPEN)/OPEN*100; 
BB8:=REF(CLOSE,1); 
BB9:=SMA(MAX(CLOSE-BB8,0),6,1)/SMA(ABS(CLOSE-BB8),6,1)*100; 
BB10:=COUNT(BB9<20,20)>=1; 
BB109:=BB7>9 AND BB10;
DRAWTEXT(BB108 OR BB109>0,L,'★拳頭'),COLORWHITE;  

上一篇文章:

下一篇文章:

 




767股票學習網 | 手機版 | 微信 | 微博 | 聯系站長





腾讯麻将怎么玩
炸金花手机版下载 中国体彩网手机版 二八杠技巧口诀论坛 后三包胆必中法哪个好呢 360重庆老时时票 全天pk10计划 pk10预测软件免费 3码倍投36期要多少钱 棋牌游戏平台 幸运飞艇怎么抓345678