首頁 股票學校 股票入門 選股 買入 看盤 跟莊 短線 炒股技巧 技術指標 k線圖 MACD 均線 成交量 股票書籍 股票視頻 網站導航

767股票學習網 > 股票學校 > 大智慧公式 > 正文

大智慧飛狐通用公式:精準黑馬

精準黑馬-- 主副圖原碼

{精準黑馬,大智慧副圖指標}{飛狐通用}
LS261:=EMA(CLOSE,2);
LS262:=EMA(CLOSE,150);
LS26:=LS261-LS262;
LS27:=EMA(LS26,100);
LS28:=2*(LS26-LS27);
LS29:=POW(LS28,3)*0.1+POW(LS28,1);
黑馬線:IF(LS28>0.1,LS29,0)*5,COLOR0066FF,LINETHICK2;
量價線:(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100,COLOR00FF00,LINETHICK1;
TJ1:=C>MA(C,250);
TJ2:=黑馬線>REF(黑馬線,1);
TJ3:=量價線>REF(量價線,1);
目標:(TJ1 AND TJ2 AND TJ3)*黑馬線,STICK,COLORWHITE,LINETHICK3;
啟動:CROSS(黑馬線,0.01)*黑馬線,STICK,COLORYELLOW,LINETHICK3;
DRAWICON(啟動>0,0.2,1);
TJ4:=COUNT(TJ2,2)=1;
TJ5:=COUNT(TJ3,2)=1;
回調:(TJ1 AND TJ2=0 AND TJ3=0 AND TJ4 AND TJ5)*黑馬線,STICK,COLOR00FF00,
LINETHICK3;
附注:⑴{起跑指標}
Var1:=LLV(L,3)<=LLV(L,60);
Var2:=C>O and (C/O>1.03 OR C/REF(C,1)>1.03);
起:if(Var1 and Var2,量價線,0),STICK,COLORRED,linethick3;
DRAWTEXT(起>0 OR 起<0 ,0.8 , '▲'),COLORRED,LINETHICK1;
Var3:=HHV(H,3)>=HHV(H,60);
Var4:=C<O and (C/O<0.97 OR C/REF(C,1)<0.97);
跑:if(Var3 and Var4,黑馬線,0),STICK,COLORFF6600,linethick3;
DRAWICON(跑>0,0.2,2);
{精準黑馬Z----一品茶緣編寫,大智慧主圖指標}{飛狐通用}
MA5:MA(C,5),COLORWHITE,LINETHICK2;
MA30:MA(C,30),COLORYELLOW,LINETHICK2;
MA250:MA(C,250),COLORRED;
黃啟白買綠回:0,COLOR00FF00;{飛狐版本請將本句加大括號,或刪除}
LS261:=EMA(CLOSE,2);
LS262:=EMA(CLOSE,150);
LS26:=LS261-LS262;
LS27:=EMA(LS26,100);
LS28:=2*(LS26-LS27);
LS29:=POW(LS28,3)*0.1+POW(LS28,1);
黑馬線:=IF(LS28>0.1,LS29,0)*5,COLOR0066FF,LINETHICK2;
量價線:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100,COLOR00FF00,LINETHICK1;
TJ1:=C>MA(C,250);
TJ2:=黑馬線>REF(黑馬線,1);
TJ3:=量價線>REF(量價線,1);
啟動:=CROSS(黑馬線,0.01)*黑馬線,STICK,COLORYELLOW,LINETHICK2;
目標:=(TJ1 AND TJ2 AND TJ3)*黑馬線,STICK,COLORWHITE,LINETHICK2;
TJ4:=COUNT(TJ2,2)=1;
TJ5:=COUNT(TJ3,2)=1;
回調:=(TJ1 AND TJ2=0 AND TJ3=0 AND TJ4 AND TJ5)*黑馬線,STICK,
COLOR00FF00,LINETHICK3;
附注:⑵{起跑指標}
Var1:=LLV(L,3)<=LLV(L,60);
Var2:=C>O and (C/O>1.03 OR C/REF(C,1)>1.03);
起:=if(Var1 and Var2,量價線,0),STICK,COLORRED,linethick3;
Var3:=HHV(H,3)>=HHV(H,60);
Var4:=C<O and (C/O<0.97 OR C/REF(C,1)<0.97);
跑:=if(Var3 and Var4,黑馬線,0),STICK,COLORFF6600,linethick3;
DRAWICON(跑>0,0.2,2);
{以下設置主圖顯示方式:}
DRAWICON(啟動>0,L-0.02,1);
STICKLINE(啟動>0,h,l,0,1),colorYELLOW,linethick2;
STICKLINE(啟動>0,o,c,4,1),colorYELLOW,linethick2;
DRAWTEXT(目標>0 ,MA30-0.02 , '○'),colorWHITE,LINETHICK1;
DRAWTEXT(回調>0 ,L*0.99 , '◆'),COLOR00FF00,LINETHICK1;
STICKLINE(回調>0 ,h,l,0,1),COLOR00FF00,linethick2;
STICKLINE(回調>0 ,o,c,4,1),COLOR00FF00,linethick2;
DRAWTEXT(起>0 OR 起<0 ,L-0.02 , '▲'),COLORRED,LINETHICK1;
DRAWICON(跑>0,L-0.05,2);
附:{黑馬跟蹤}指標原碼:
{黑馬跟蹤----創幻貴賓沉思思編寫,一品優化版,各種軟件通用}
n1:=barslast(cross(C,MA(C,5)));
n2:=barslast(cross(MA(c,5),c));
黑馬:if(n1<n2,n1+1,0),COLOR00FFFF,linethick2;
跟蹤:if(n2<n1,n2+1,0),COLORFF00FF,linethick2;
漲:(c-ref(c,黑馬))/ref(c,黑馬)*100,COLOR0000FF;
STICKLINE(漲>黑馬,黑馬,漲,1,1),COLORFFFFFF;
跌:(c-ref(c,跟蹤))/ref(c,跟蹤)*100,COLORFFFF00;
STICKLINE(ABS(跌)>ABS(跟蹤),-跟蹤,跌,1,1),COLORFF6600;
ZF:(C-REF(C,1))/REF(C,1)*100,COLOR00FF00,POINTDOT,LINETHICK0;
LXSZ:=黑馬>=2 AND 黑馬<=4 AND COUNT(ZF>0,3)>=2;
XGL:=(C-MA(C,5))/MA(C,5)*100<2 OR (L-MA(C,5))/MA(C,5)*100<2 AND ZF<3;
騎馬:(REF(LXSZ,1) AND (ZF<1 OR XGL))*黑馬,COLOR00FF00,LINETHICK2;
登高:黑馬>5 AND ZF>0 AND COUNT(ZF>0,3)>=2 AND COUNT(漲>18,2),POINTDOT,
COLORFFFFFF,LINETHICK2;
下馬:(ZF<0 AND REF(登高,1))*漲,COLORFFFF00,LINETHICK2;
STICKLINE(登高=1,18,漲,4,0),COLORFFFFFF;
STICKLINE(黑馬=1,0,5,4,0),COLOR00FFFF;
STICKLINE(跟蹤=1,0,5,4,1),COLOR00FF00;
if(n2<n1,-(n2+1),0),COLORFFFFFF,linethick1;  

上一篇文章:

下一篇文章:

 




767股票學習網 | 手機版 | 微信 | 微博 | 聯系站長





腾讯麻将怎么玩
时时彩全网计划 pk10直播开奖赛车 重庆肘时彩开奖历史 永城网络彩票 捕鱼达人2经典版游戏 合德记是不是主做线上 重庆肘时彩历史最大奖 万汇娱乐彩票登录平台 pk10北京pk拾大小计划 广东时时网站注册